# Ports collection makefile for:  pear-Net_LDAP
# Date created:			  26 June 2004
# Whom:				  Gerrit Beine (<tux@pinguru.net>)
#
# $FreeBSD: ports/net/pear-Net_LDAP/Makefile,v 1.10 2007/12/18 00:03:55 miwi Exp $
#

PORTNAME=	Net_LDAP
DISTVERSION=	1.0.0
CATEGORIES=	net pear

MAINTAINER=	gerrit.beine@gmx.de
COMMENT=	OO interface for searching and manipulating LDAP-entries

BUILD_DEPENDS=	${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
RUN_DEPENDS=	${BUILD_DEPENDS}

USE_PHP=	ldap
CATEGORY=	Net
FILES=		LDAP.php \
		LDAP/Entry.php LDAP/Filter.php LDAP/RootDSE.php \
		LDAP/Schema.php LDAP/Search.php LDAP/Util.php
DOCS=		README.txt RootDSE.txt Schema.txt utf8.txt manual.html
_DOCSDIR=	doc
TESTS=		AllTests.php Net_LDAPTest.php \
		Net_LDAP_EntryTest.php Net_LDAP_FilterTest.php \
		Net_LDAP_RootDSETest.php Net_LDAP_SearchTest.php \
		Net_LDAP_UtilTest.php
EXAMPLES=	add_entry.php connecting.php fetch_entry.php \
		modify_entry.php modify_entry2.php search_entries.php
_EXAMPLESDIR=	doc/examples

.include <bsd.port.pre.mk>
.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
.include <bsd.port.post.mk>


syntax highlighted by Code2HTML, v. 0.9.1